Was this helpful?

On Wednesday, May 7, 2014, we released a quarterly version of Apigee Edge on-premises.

If you have questions, go to Apigee Customer Support.

For a list of all Apigee Edge release notes, see Apigee Edge Release Notes.

New features and enhancements

Following are the new features and enhancements in this release.

  • Java 7 support
    Edge supports Java 1.7 in addition to Java 1.6.
  • Gradual, parallel deployment
    Deploy different versions of an API proxy in parallel, sending different percentages of traffic to each. Gradual deployment lets you test new versions of an API proxy with smaller amounts of traffic prior to full deployment.
  • Multi-datacenter analytics
    Edge analytics is now supported in deployments that use multiple datacenters. Analytics Services tracks the router and message processor on which an API request was handled.
  • Display Monetization billing documents in HTML format
    Monetization now displays billing documents to end users in HTML format. If you want to provide billing documents as PDF files, you can integrate monetization with a billing system that provides PDF generation or license a supported third-party PDF library.
    See Create billing documents.
  • JMS for multi-datacenter deployments
    JMS listeners are now deployed to all routers, allowing inbound JMS endpoints to be deployed in multi-datacenter environment.

This release also contains features and bug fixes from the following cloud releases:

Bugs fixed

Topic Description
Incorrect password set When creating a password with the word "admin" in it, Edge replaced "admin" with the administrator email ID from the UI config file. Edge now no longer replaces "admin" when used in a password.
min_permsize In the setenv.sh script, you can now set the min_permsize argument to reduce server startup time.
get_pid() in etc/init.d/message-processor The functionality of etc/init.d/message-processor was broken if Edge is installed in a directory containing "sh" in the path; for example, /home/shark/apigee4. This issue has been resolved.
backup.sh and backup-ui.sh Issues with OPDK_VERSION in backup.sh and backup-ui.sh scripts for Edge on-premises versions 14.01.x.x have been resolved.
Case: 812644
Bundle delete/undeploy When API proxy bundles were undeployed or deleted using either the Edge management UI or the apigeetool script, deployment errors sometimes occurred. This issue has been resolved.
Case: 814941

 

Help or comments?

  • Something's not working: See Apigee Support
  • Something's wrong with the docs: Click Send Feedback in the lower right.
    (Incorrect? Unclear? Broken link? Typo?)